Announcements

We're here to help you whenever you need us.

USING SAFARI BROWSER AND PAYMENT

Wednesday, August 8, 2012


Hello Everyone, It seems that there are issues for some users trying to pay their invoices while using the Safari browser, I am contacting my merchant gateway (Quantum) about this in hopes to resolve this. Please use an alternative browser such as Mozilla FireFox, Google Chrome, or Opera to make payments on invoices for the time being. I sincerely apologize for the inconvenience. Best...

More »




A little network trouble

Monday, August 6, 2012


Good Morning everyone, If you noticed your site was inaccessible this morning for a few minutes (around 9:15am), this was due to a main network hub in Miami that routes traffic for DimeNoc datacenter going down. Staff have redirected traffic to a different provider (Level3) and everything should be resolving again. I apologize for the inconvenience. Kelly




Important: Billing Changes

Thursday, May 24, 2012


Hello Everyone! Recently, we've made some changes on how we process and store credit card payments. Twenty70 Hosting will no longer be storing credit card information on our servers or processing transactions through our website. All transactions will now be processed through our merchant, Quantum Gateway and your credit card information will be stored within their credit card "Vault". You...

More »




Happy 2012, i.am.blogger $5/mo WordPress Hosting is Back!

Monday, January 2, 2012


We've relaunched i.am.blogger for a limited time. $5/mo WordPress hosting for new blogs only! Also, earn a $5 credit or $5 towards a giftcard of your choice by referring people to Twenty70. Check out details here: http://wp.me/pW6ln-1U    




cPanel 11.25 Stable Release

Wednesday, March 3, 2010


cPanel look a little bit different? Don't worry, we've upgraded cPanel to the latest STABLE release which is 11.25. To find out more about cPanel 11.25, please visit http://cPanel.net :-)   Best, Kelly M.  




Wordpress 2.8.6

Thursday, November 12, 2009


Hi there Twenty70ers, Wordpress 2.8.6 has been released to patch a vulnerability. Please make sure you update your Wordpress Blogs asap. :-) Team Twenty70




Linux Kernel Upgrade - November 13th - 8:00pm EST

Wednesday, November 11, 2009


To ensure we continue to offer the most secure, reliable shared hosting has to offer, we will be upgrading a Linux Kernel due to new vulnerability that has been discovered. This will require all of our servers to be rebooted using the new Kernel so you may experience 5 - 10 minutes of downtime at most. We do apologize for the inconvenience. Team Twenty70




PHP Upgrade

Wednesday, November 4, 2009


Valued Clients, PHP has been successfully upgraded on all servers from version 5.2.10 to 5.2.11. If you have any questions or concerns, please feel free to contact us. Thank you, Team Twenty 70

More »





Next Page »

RSS View RSS Feed


Powered by WHMCompleteSolution

Copyright © 2009 - 2015 Twenty70Hosting - All Rights Reserved.